Nicolas Chevobbe

2016 Challenge : Week #11

If you did not, read the initial blog post announcing the challenge

At the start of the week, I was waiting for Brian Grinstead to review a patch for Bug 1246514, which aimed to switch the devtools option panel from XUL to HTML.
Brian made some minor comments on my patch, and after addressing them, I was able to push again to review and got finally r+. As I don’t have commit access, when one of my patch is r+, I have to put a “checkin-needed” flag in Bugzilla. A sheriff would then push my patch to the repository. This could take some times, and for this patch, when the sheriff tried to apply the patch to his repository, it failed. It failed because in the meantime, other commits landed to fx-team, which modify some files which were in my patch too.
So I had to pull and rebase my commits for my patch to be valid and properly pushed to the repository. I should take care of this, or at least, take it into account when evaluating time for my challenge.

Bugzilla Timeline - Week 11
Week 11 - Success

Most of the week I worked on Bug 1250835. This would add a swatch before angle values and allow to cycle through units ( degree, radian, gradian and turn) with shift + click, just like it can already be done for the color values.

Cycle through angle units
Cycle through angle units

For doing this, I studied how this was done for the color swatches and tried to stay consistent. I created a css-angle helper class which computed the conversion between the various possible angle units. I had to remember my trigonometry school classes ( hear searched the internet to get the formulas ), and I created both unit and browser tests to make sure everything was ok. I’m ready to ask for review on this, I just have to wait tomorrow to ask who would be best suited for it.

On Friday, Patrick Brosset pinged me on IRC to ask me if I was willing to work on Bug 1257874. A new function just landed to get the animated properties and their keyframes ( i.e. values for the property on declared offsets ). This new function should be called instead of the existing one, getFrames, because getFrames’s return value will change in the future, and thus would not be suited to what we want in the animation detail.
I took the bug, and out of curiosity, had a look at where the getFrames function was called on Friday evening. As it did not look to hard, I modified the function call and adapted one function and a couple of tests to match the returned object structure. Things went quite smooth and I pushed to review during the night.

As in Week #10, I attended the weekly devtools team meeting. There were some discussion on the prioritization of the bugs ( namely, what P1 means and what it should means ).
Jame Longster ( @jlongster ) set up a skeleton for a central place for devtools documentation in order to gather all the knowledge each of member of the team has but isn’t written down. From a contributor point of view, it is great ! For now documentation is pretty scattered between MDN, in-repository md files,… so this would help newcomers to better understand how the devtools works.
Bryan Clark ( @clarkbw ) told the team that there is an ongoing effort to display better error messages in the console. The idea is to provide a link to MDN along with the error itself to allow the user to better understand what’s going wrong ( and prevent copying/pasting the error right up in Stackoverflow ). I think this will be great.

I’m quite pleased of how the things are going for now. I have several bugs to work on and members of the team point me to new bugs which is great. I feel more confident in my ability to complete my challenge than in the begining of the year which means this project is going great ! Hopefully I’ll try to keep it that way !